Skip to content

Commit

Permalink
wayland: refresh patches to apply on 1.17.0 version
Browse files Browse the repository at this point in the history
:Release Notes:

:Detailed Notes:
Fixes:
ERROR: wayland-1.17.0-r0 do_patch: Command Error: 'quilt --quiltrc raspberrypi4-webos-linux-gnueabi/wayland/1.17.0-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0  Output:
Applying patch 0003-Enhance-Wayland-debug-print.patch
patching file Makefile.am
patching file configure.ac
patching file src/connection.c
Hunk #2 succeeded at 1295 (offset 8 lines).
Hunk #3 FAILED at 1330.
1 out of 3 hunks FAILED -- rejects in file src/connection.c
patching file src/wayland-client.c
Hunk #1 succeeded at 751 (offset 3 lines).
Hunk #2 succeeded at 1426 (offset 3 lines).
patching file src/wayland-private.h
patching file src/wayland-server.c
Hunk #3 succeeded at 1029 (offset 33 lines).
Hunk #4 succeeded at 1139 (offset 33 lines).
Hunk #5 succeeded at 1210 (offset 33 lines).
patching file src/wayland-util.c
Patch 0003-Enhance-Wayland-debug-print.patch does not apply (enforce with -f)
ERROR: wayland-1.17.0-r0 do_patch:
ERROR: wayland-1.17.0-r0 do_patch: Function failed: patch_do_patch

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[PLAT-77937] Create GPVB with Yocto 2.7
[PLAT-115142] CCC: Upgrade to Yocto 2.7 Warrior

Change-Id: I19cf84fddd7b06cb4111a8b092259fecc031e5ee
  • Loading branch information
shr-project authored and Hyunjae Shin committed Sep 26, 2020
1 parent 7dc0dca commit eaf9b06
Show file tree
Hide file tree
Showing 3 changed files with 27 additions and 23 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 2e360ea8199c0d96e48994723a510c0d9c3eeb01 Mon Sep 17 00:00:00 2001
From 6e746799c710bfcee0983f7d7598c191007e2cc3 Mon Sep 17 00:00:00 2001
From: Hyunkook Khang <hyunkook.khang@lge.com>
Date: Tue, 20 Sep 2016 10:25:36 +0900
Subject: [PATCH] server: Fix crash when accessing client which is already
Expand All @@ -20,10 +20,10 @@ Upstream-Status: Submitted
1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/src/wayland-server.c b/src/wayland-server.c
index eae8d2e..0e07746 100644
index 19f6a76..20681e6 100644
--- a/src/wayland-server.c
+++ b/src/wayland-server.c
@@ -1253,10 +1253,16 @@ wl_display_terminate(struct wl_display *display)
@@ -1286,10 +1286,16 @@ wl_display_terminate(struct wl_display *display)
WL_EXPORT void
wl_display_run(struct wl_display *display)
{
Expand All @@ -40,7 +40,7 @@ index eae8d2e..0e07746 100644
wl_event_loop_dispatch(display->loop, -1);
}
}
@@ -1274,7 +1280,7 @@ wl_display_flush_clients(struct wl_display *display)
@@ -1307,7 +1313,7 @@ wl_display_flush_clients(struct wl_display *display)
WL_EVENT_WRITABLE |
WL_EVENT_READABLE);
} else if (ret < 0) {
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 78efe2bbe3a0b84ab72cc49bbc2f92715f8b665d Mon Sep 17 00:00:00 2001
From 33b19050622db5269ff3e8dd8ed6a5ce49de38e4 Mon Sep 17 00:00:00 2001
From: Jaeyoon Jung <jaeyoon.jung@lge.com>
Date: Mon, 13 Aug 2018 14:29:34 +0900
Subject: [PATCH] client: Exit on a fatal connection error
Expand All @@ -17,7 +17,7 @@ Upstream-Status: Inappropriate [webOS specific]
1 file changed, 7 insertions(+)

diff --git a/src/wayland-client.c b/src/wayland-client.c
index 0ccfc66..4c0c46e 100644
index b0805f1..49b7df5 100644
--- a/src/wayland-client.c
+++ b/src/wayland-client.c
@@ -152,6 +152,13 @@ display_fatal_error(struct wl_display *display, int error)
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From dc5ad3922246a0a6fdce230bd95cc638d9f587c2 Mon Sep 17 00:00:00 2001
From 67c72d6e95e9895363271b347b6670bd8d3fc53b Mon Sep 17 00:00:00 2001
From: Jaeyoon Jung <jaeyoon.jung@lge.com>
Date: Tue, 27 Jan 2015 16:45:01 +0900
Subject: [PATCH] Enhance Wayland debug print
Expand All @@ -17,15 +17,15 @@ Upstream-Status: Inappropriate [webOS specific]
---
Makefile.am | 14 ++++++
configure.ac | 12 +++++
src/connection.c | 103 ++++++++++++++++++++++++++++++++++--------
src/connection.c | 105 ++++++++++++++++++++++++++++++++++--------
src/wayland-client.c | 6 +--
src/wayland-private.h | 2 +-
src/wayland-server.c | 80 +++++++++++++++++++++++++++++++-
src/wayland-util.c | 18 ++++++++
7 files changed, 211 insertions(+), 24 deletions(-)
7 files changed, 212 insertions(+), 25 deletions(-)

diff --git a/Makefile.am b/Makefile.am
index 697c517..a3d2b57 100644
index f47d055..c9c1678 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,12 @@ libwayland_util_la_CFLAGS = $(AM_CFLAGS)
Expand Down Expand Up @@ -64,7 +64,7 @@ index 697c517..a3d2b57 100644
libwayland_client_la_SOURCES = \
src/wayland-client.c
diff --git a/configure.ac b/configure.ac
index f05fba4..f27a5d1 100644
index 8d56f2b..9641445 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,13 @@ AM_CONDITIONAL(USE_HOST_SCANNER, test "x$with_host_scanner" = xyes)
Expand Down Expand Up @@ -94,7 +94,7 @@ index f05fba4..f27a5d1 100644
AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])

diff --git a/src/connection.c b/src/connection.c
index f965210..29164be 100644
index 7fba999..0cf2e18 100644
--- a/src/connection.c
+++ b/src/connection.c
@@ -64,6 +64,49 @@ struct wl_buffer {
Expand Down Expand Up @@ -147,7 +147,7 @@ index f965210..29164be 100644
struct wl_connection {
struct wl_buffer in, out;
struct wl_buffer fds_in, fds_out;
@@ -1244,18 +1287,41 @@ wl_closure_queue(struct wl_closure *closure, struct wl_connection *connection)
@@ -1252,18 +1295,41 @@ wl_closure_queue(struct wl_closure *closure, struct wl_connection *connection)
}

void
Expand Down Expand Up @@ -192,7 +192,7 @@ index f965210..29164be 100644
time / 1000.0,
send ? " -> " : "",
target->interface->name, target->id,
@@ -1264,50 +1330,51 @@ wl_closure_print(struct wl_closure *closure, struct wl_object *target, int send)
@@ -1272,53 +1338,54 @@ wl_closure_print(struct wl_closure *closure, struct wl_object *target, int send)
for (i = 0; i < closure->count; i++) {
signature = get_next_argument(signature, &arg);
if (i > 0)
Expand All @@ -215,8 +215,12 @@ index f965210..29164be 100644
wl_fixed_to_double(closure->args[i].f));
break;
case 's':
- fprintf(stderr, "\"%s\"", closure->args[i].s);
+ fprintf(debug_fp, "\"%s\"", closure->args[i].s);
if (closure->args[i].s)
- fprintf(stderr, "\"%s\"", closure->args[i].s);
+ fprintf(debug_fp, "\"%s\"", closure->args[i].s);
else
- fprintf(stderr, "nil");
+ fprintf(debug_fp, "nil");
break;
case 'o':
if (closure->args[i].o)
Expand Down Expand Up @@ -260,10 +264,10 @@ index f965210..29164be 100644

static int
diff --git a/src/wayland-client.c b/src/wayland-client.c
index 4c0c46e..bf44b81 100644
index 49b7df5..f66fb91 100644
--- a/src/wayland-client.c
+++ b/src/wayland-client.c
@@ -748,7 +748,7 @@ wl_proxy_marshal_array_constructor_versioned(struct wl_proxy *proxy,
@@ -751,7 +751,7 @@ wl_proxy_marshal_array_constructor_versioned(struct wl_proxy *proxy,
wl_abort("Error marshalling request: %s\n", strerror(errno));

if (debug_client)
Expand All @@ -272,7 +276,7 @@ index 4c0c46e..bf44b81 100644

if (wl_closure_send(closure, proxy->display->connection))
wl_abort("Error sending request: %s\n", strerror(errno));
@@ -1423,13 +1423,13 @@ dispatch_event(struct wl_display *display, struct wl_event_queue *queue)
@@ -1426,13 +1426,13 @@ dispatch_event(struct wl_display *display, struct wl_event_queue *queue)

if (proxy->dispatcher) {
if (debug_client)
Expand Down Expand Up @@ -302,7 +306,7 @@ index 29516ec..c6eaa60 100644
void
wl_closure_destroy(struct wl_closure *closure);
diff --git a/src/wayland-server.c b/src/wayland-server.c
index 0e07746..f8e27cb 100644
index 20681e6..7567b23 100644
--- a/src/wayland-server.c
+++ b/src/wayland-server.c
@@ -137,6 +137,7 @@ struct wl_protocol_logger {
Expand Down Expand Up @@ -330,7 +334,7 @@ index 0e07746..f8e27cb 100644

if (!wl_list_empty(&display->protocol_loggers)) {
message.resource = resource;
@@ -989,6 +996,71 @@ bind_display(struct wl_client *client, struct wl_display *display)
@@ -1022,6 +1029,71 @@ bind_display(struct wl_client *client, struct wl_display *display)
return 0;
}

Expand Down Expand Up @@ -402,7 +406,7 @@ index 0e07746..f8e27cb 100644
/** Create Wayland display object.
*
* \return The Wayland display object. Null if failed to create
@@ -1034,6 +1106,8 @@ wl_display_create(void)
@@ -1067,6 +1139,8 @@ wl_display_create(void)

wl_array_init(&display->additional_shm_formats);

Expand All @@ -411,7 +415,7 @@ index 0e07746..f8e27cb 100644
return display;
}

@@ -1103,6 +1177,8 @@ wl_display_destroy(struct wl_display *display)
@@ -1136,6 +1210,8 @@ wl_display_destroy(struct wl_display *display)

wl_list_remove(&display->protocol_loggers);

Expand Down

0 comments on commit eaf9b06

Please sign in to comment.